Home > Failed To > Failed To Build Gem Native Extension Win32-service

Failed To Build Gem Native Extension Win32-service

Contents

xcode-select --install -Installing the Xcode Command Line Tools are the key to getting Compass working on OS X 3. This could take a while...
ERROR: Error installing win32-service-0.5.2.gem:
ERROR: Failed to build gem native extension. In general, you will not need this update unless you are using a version of Ruby prior to 1.8.6. (source: 1.2.4. I'm not entirely sure what the core issue is. have a peek here

Results logged to C:/Ruby191/lib/ruby/gems/1.9.1/gems/win32- service-0.5.2/gem_ma ke.out c:\> Report post Edit Move Delete topic Reply with quote Re: ERROR: Failed to build gem native extension (win server 2003/2008 ruby 1.9.1/1.8.7) Andy Ho Rebooting the OS will let you install the service again. sercanesen commented Dec 25, 2015 "gem update --system 2.3.0" worked for me too. windows ruby gem share|improve this question edited Feb 25 '09 at 19:35 asked Sep 4 '08 at 13:40 Charles Roper 10.6k175590 add a comment| 6 Answers 6 active oldest votes up

Error Failed To Build Gem Native Extension Windows

Pages 1 Posts [ 6 ] 1 Topic by zbo09 2007-11-25 09:24:38 zbo09 Registered: 2006-12-03 Posts: 18 Topic: Failed to build gem native extension - nmake' is not recognized! There's probably a far, far better way in this scenario.) Member indirect commented Jan 14, 2016 @duckinator awesome, thanks for figuring this out! current directory: C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/libv8-3.11.8.17/ext/libv8 C:/Ruby23-x64/bin/ruby.exe -r ./siteconf20160904-1872-1kytt9l.rb extconf.rb creating Makefile The system cannot find the path specified. ruby osx terminal compass-sass share|improve this question edited Mar 20 '14 at 20:59 asked Mar 20 '14 at 20:49 cusejuice 2,590133772 possible duplicate of Ruby Gem install Json fails

After that, you can install Compass: sudo gem install compass share|improve this answer answered Jul 21 '15 at 21:23 Gratz 412 add a comment| up vote 2 down vote On yosemite, On Windows, when I do this: gem install sqlite3-ruby I get the following error: Building native extensions. This could take a while... Failed To Build Gem Native Extension Windows 10 Ruby 2.2.0, still getting exit code 2 with many "warning: cast to pointer from integer of different size (-Wint-to-pointer-cast) (Windows 8.1 x64; or 6.3.9600).

Stop. Error Installing Json Failed To Build Gem Native Extension How do I install the latest compass without error? Existing account User name or e-mail address Password Always use SSL (experimental!) NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? share|improve this answer answered Oct 28 '16 at 12:39 Eridana 601411 add a comment| up vote 0 down vote you must have gcc,json_pure i collect some information from several post sudo

net1957 commented Sep 10, 2014 I confirm that gem update --system 2.3.0 is working (windows 8.1 x64) but 2.4.0 and 2.4.1 fails (ruby 1.9.3p545 (2014-02-24) [i386-mingw32]) wstaples referenced this issue in Error Installing Rails: Error: Failed To Build Gem Native Extension. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count). What I did is to uninstall the ruby version I installed previously with aptitude and then I installed it again with following the instructions at: rvm.io/rvm/install. You must run xcode-select --install for gem install compass to work.

Error Installing Json Failed To Build Gem Native Extension

share|improve this answer answered Apr 5 '14 at 22:56 A. more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed Error Failed To Build Gem Native Extension Windows Download and extract DevKit-tdm-32-4.5.2-20111229-1559-sfx.exe (the one for 1.8.7 and 1.9.3) Follow the rest of the DevKit quick start instructions: https://github.com/oneclick/rubyinstaller/wiki/Development-Kit#quick-start Ensure they are in your PATH. Make Failed Exit Code 2 Ruby Added by Oliver Weinmann over 2 years ago.

I am about to tell my company to forget about windows, but before I do, has anyone made it through this? navigate here If the gem doesn't specify that it is platform specific, the gem system probably assumes that it is a platform-agnostic gem and tries to install it. –Nathan Fritz Sep 4 '08 j-horiba commented Jan 14, 2015 gem update --system 2.3.0 worked for me too. This could take a while... Extconf.rb Failed Windows

Both with the same result. As I understand it I need to have cl executable in the ruby bin folder, but where do I get it?Anyone had the same problem or can anyone point me into Would you like to answer one of these unanswered questions instead? Check This Out no checking for sqlite3.h...

I'm so happy! Extconf Failed, Exit Code 1 Sign in Register Home Projects Help Search: Redmine Overview Download Activity Roadmap Issues News Wiki Forums Repository Forums » Help » install win32-service Added by Dieudo FASS about 5 years ago Skip to forum content

A forum for Ruby on Rails users Index User list Search Failed to build gem native extension - nmake' is not recognized!

I'll have to look at the comments on this commit.

  1. Might be worth tagging onto your answer. –Bruford Jun 17 '15 at 14:06 | show 1 more comment up vote 25 down vote I struggled with you same issue for about
  2. Tnx! –e-sushi Mar 15 '15 at 6:06 | show 9 more comments up vote 85 down vote In order to install compass On Mac OS X 10.10 (Yosemite)had to perform the
  3. Hopefully that's not an issue, since there's a free compiler available.
  4. Let's make that change and release a new 2.5.x version with the fix.

You signed out in another tab or window. There's also a libsqlite3-ruby which I installed but I don't know if that made any difference –mvexel Dec 30 '10 at 19:10 add a comment| up vote 2 down vote Is Until that is fixed, please revert to older version of RubyGems. Mkmf.rb Can't Find Header Files For Ruby This could take a while...

Thank you very much! –arik Dec 19 '16 at 23:54 add a comment| up vote 19 down vote The best way is sudo apt-get install ruby-compass to install compass. When trying 'gem install mongrel_service' it gives me almost the same error.C:\>gem install mongrel_service --include-dependenciesINFO: `gem install -y` is now default and will be removedINFO: use --ignore-dependencies to install only the http://main.nationalmssociety.org/site/TR/Bike/TXH... this contact form For future reference, I could install using --platform mswin32.

yes creating Makefile make gcc -I. -I. -IC:/Ruby187/lib/ruby/1.8/i386-mingw32 -I. -DHAVE_REGISTERSERVICECTR LHANDLEREX -g -O2 -DFD_SETSIZE=256 -c win32/daemon.c win32/daemon.c: In function 'Ruby_Service_Ctrl': win32/daemon.c:141:7: error: '__try' undeclared (first use in this function) win32/daemon.c:141:7: note: Results logged to c:/ruby/lib/ruby/gems/1.8/gems/rcov-0.8.1.2.0/ext/rcovrt/gem_make.out Last edited by zbo09 (2007-11-25 09:36:00) 2 Reply by vanlunteren 2007-11-29 19:02:22 vanlunteren From: Rotterdam, The Netherlands Registered: 2007-10-11 Posts: 3 Re: Failed to build gem native copiousfreetime added ready for work triage labels Jan 8, 2016 Member duckinator commented Jan 8, 2016 Reproduced on Windows 8.1. Reload to refresh your session.

ERROR: Error installing json: ERROR: Failed to build gem native extension. This could take a while... share|improve this answer answered Aug 24 '16 at 20:13 JamesWilson 203213 add a comment| up vote 1 down vote sudo gem update --system sudo gem install compass share|improve this answer answered make failed, exit code 2 Gem files will remain installed in C:/Ruby193/lib/ruby/gems/1.9.1/gems/json-1.8.1 for inspection.

Set Up Ruby Environment Ensure ruby is installed and up to date: ruby -v Update gem's sudo gem update --system 2. I still have to use the solution I mention a few posts above. gem update --system 2.3.0 worked for me. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will

crmckenzie commented Feb 22, 2015 👍 to @gparvind 's question about when will this be fixed. c:/ruby/bin/ruby.exe extconf.rb instal rcov creating Makefile This was referenced May 30, 2015 Closed Fix RubyGems < 2.4 on Ruby 2.2.x AnthonyMastrean/chocolateypackages#103 Closed error podio/podio_rails_sample#3 jameskerr commented Jul 7, 2015 Downgrading to 2.3.0 worked for me too! no checking for rb_thread_blocking_region()...

ERROR: Error installing json: ERROR: Failed to build gem native extension. Member luislavena commented Aug 19, 2014 @ishristov as commented before and also on RubyInstaller mailing list, if you're using Ruby 1.9.3, please downgrade to 1.8.29: https://groups.google.com/d/topic/rubyinstaller/k19SeJijpKU/discussion XhmikosR commented Sep 5, 2014